Super learner
This user is a Super Learner. To become a Super Learner, you need to reach Level 8.
Last answered:

25 Oct 2023

Posted on:

25 Oct 2023


Collecting package metadata (current_repodata.json): failed

CondaSSLError: Encountered an SSL error. Most likely a certificate verification issue.

Exception: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /pkgs/main/win-64/current_repodata.json (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available."))

1 answers ( 0 marked as helpful)
Posted on:

25 Oct 2023


The error you've encountered is due to an SSL certificate verification issue when trying to access the Anaconda repositories. It's specifically saying that the SSL module isn't available. This can happen due to various reasons, and there are several ways you can try to resolve this issue:

1. Update Conda

First, it's a good idea to make sure you have the latest version of Conda. Outdated versions might have issues that have been resolved in later versions.

 conda update conda

2. Check Your SSL Certificates: 

Conda uses OpenSSL for SSL support. If OpenSSL isn't configured properly or if certain certificates are missing, you might run into this issue.

You can try setting the REQUESTS_CA_BUNDLE environment variable to point to your certificate file:

export REQUESTS_CA_BUNDLE=/path/to/your/certificate.pem

3. Disable SSL Verification (Not Recommended): For a temporary fix, or if you're sure about the safety of your connection, you can disable SSL verification:

conda config --set ssl_verify false

Hope this helps!

Submit an answer