The 365 Data Science team is proud to invite you to our own community forum. A very well built system to support your queries, questions and give the chance to show your knowledge and help others in their path of becoming Data Science specialists.
Ask
Anybody can ask a question
Answer
Anybody can answer
Vote
The best answers are voted up and moderated by our team

Tableau – “Number of Records” not generated

Tableau – “Number of Records” not generated

0
Votes
7
Answer

Hello, I am stuck in the lesson Tesla – “Creating Custom fields”.
In my Tableau Desktop v.020.20.0415.1946 64-bit, when I generate the data, the field “Number of records” is not automatically generated, as it is shown on videos. On the other hand, I get another field which is not shown on the videos, called “Data (Count)”. Unfortunately, the latter cannot be used the same way as you use the Number of records in the next videos.
Could you please provide some instructions on how to create the measure “Number of records”, or on how to force Tableau to automatically generate this field. 
N.B. To avoid any further mismatch problems like this, it would be nice to have the latest Tableau version used in your videos.
Thank you very much for your assistance.

7 Answers

Top Answer

3
Votes

Hello,
I had the same issue this morning because I also have the latest version of Tableau so I checked online. So the Data (count) seems to be the same as the “number of records” but is a non-aggregate argument unlike the number of records. In the calculation field you would have to add “{fixed: ” as a prefix to the data (count). Please note that you have to drag and drop the data (count) into the opened dialog box so that you would get the function for the data (count) 《I think it is something like Count ([data]) I am not really sure》.
 
So it should look like this:
[Price]*{fixed: Count ([data])}
**Please note that I am not sure of the proper arrangement of the function for data (count). 
 
Also in the end you may not need to use it because it looks like the latest version of Tableau already did the multiplication as the value of price ie. calculated the revenue as price.
So if you drag and drop your price into the sheet, you will notice that the figures are the same as the revenue in the video. 
 

The reason why the fixed prefix is added is so that Tableau can read it as an aggregate argument because it is the result of the count function. Just like how count in excel is seen as ‘general’ not ‘numerical’, I think that’s what’s happened there.

Perfectly working now…thanks for the answer……if anyone facing such issue just go to create a calculated field and create using “{fixed: Count ([Transaction ID])}*. this might help

2 months

0
Votes

I am also having the same issue. They need to get this sorted

0
Votes

Hi, am having the same issue right now. I’ve tried to manipulate the data, but couldn’t generate the “number of records”

Oh, I think its best to download the lesson 7 tableau file and do the calculations in there. that solves the problem ultimately.

5 months

How do you do that?

5 months

Hi, only add a calculation field, name Number of Records, in formula space just harcode the value 1
 
 

This was the simplest way to do it and worked..thanks Luis

5 days

0
Votes

I also noticed similar problem and think that explanation for “Revenue” calculated field in the video might be incorrect. This is because the Price is different for each row. If the price was same then it would make sense to just multiply the Price with total count for a month to get total revenue. Regardless of this, the calculation somehow appears correctly. This may be due to some other unexplained feature or behavior. Instead of creating a calculated field (“Revenue”) and then dragging it over a specific thing the process is actually much simpler. Remove the “Number of Records” or SUM(Revenue) column and ignore whatever is mentioned about these in the video. Instead just drag the Price field next to the Month and it will show you the SUM(Price) which is the Revenue. You can click on this field in the “Marks” pane and in the “Measure” option select Count to display a count instead of SUM. It’s this simple. No need to create calculated field.

2
Votes

One simple way to create “Number of records” calculate field is just with 1: Create a calculated filed with ‘1’

This saved me so much time, I was on the verge of putting my laptop on the floor and kicking the screen off it in frustration. Thank you so much.

2 weeks

0
Votes

Tableau didn’t auto generate it for me when I converted Region to ‘States/Province’ so I hardcoded it by created a calculated field using COUNT().

×
LAST CHANCE
Ready to Learn Data Science?
50% OFF