Last answered:

22 Nov 2023

Posted on:

14 Nov 2023


help to solve this

set @@global.sql_mode := replace(@@global.sql_mode, 'ONLY_FULL_GROUP_BY', ''); 

after using this commans the row affecting is zero what can i do now?? 

1 answers ( 0 marked as helpful)
Posted on:

22 Nov 2023


Hi Magesh!
Thanks for reaching out.

If the command SET @@global.sql_mode := REPLACE(@@global.sql_mode, 'ONLY_FULL_GROUP_BY', ''); affected 0 rows, it means that the 'ONLY_FULL_GROUP_BY' setting was not present in the sql_mode to begin with, or it was successfully removed.

The '0 rows affected' message in this context is not indicative of an error or problem. It's simply stating that the global SQL mode setting has been updated, but no data rows were "affected" because this operation alters a server configuration rather than modifying data in a database table.

Hope this helps.

Submit an answer