The 365 Data Science team is proud to invite you to our own community forum. A very well built system to support your queries, questions and give the chance to show your knowledge and help others in their path of becoming Data Science specialists.
Ask
Anybody can ask a question
Answer
Anybody can answer
Vote
The best answers are voted up and moderated by our team

reading data in tableau

reading data in tableau

0
Votes
2
Answer

Every time I try to read csv file in tableau (while reading I indicate that it is a csv file) the program displays it unsparated. And when I split it separates the columns, but gives to every column identical “integrated” name. How may I solve it?
(for example: first column: “Reason_1,Reason_2…” , second column:”Reason_1,Reason_2…”

2 Answers

365 Team
0
Votes

Hi Макс!
Thanks for reaching out.
Can you please specify how did you actually split the columns? 
Please feel free to upload an image in https://imgur.com/ and then share it with us, so that we can better understand the operations you are referring to.
Otherwise, please consider changing the language and regional settings of your computer, as they might be the reason for this issue, because they relate to the use of different delimiters (comma – , , or semicolon – ;, for instance). 
Hope this helps.
Best,
Martin

365 Team
0
Votes

Hi Макс!
Thank you for your reply.
Can also try to export the file as a ;-separated *.csv from SQL. Then, when you open that file in Tableau, it will work in case this has been currently set as a separator character in your system.
Then, you can alter the Language & Region settings from your System Preference. If Region has been set to United States, you should be able to use commas as opposed to semicolons. Please feel free to try a few regions to come across the correct/suitable settings.
Hope this helps but please feel free to get back to us should you need further assistance. Thank you.
Best,
Martin