🛠️ Scheduled Maintenance | We’ll be undergoing scheduled maintenance and upgrades between 00:00 PST Jan 26th until 00:00 PST Jan 28th. There may be brief interruption of services in that period. We apologize for the inconvenience.

The 365 Data Science team is proud to invite you to our own community forum. A very well built system to support your queries, questions and give the chance to show your knowledge and help others in their path of becoming Data Science specialists.
Anybody can ask a question
Anybody can answer
The best answers are voted up and moderated by our team

SQL DELETE Statement

SQL DELETE Statement


The following error arises:
09:31:24 delete from departments_dup where dept_no = ‘d003’ Error Code: 1175. You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column. To disable safe mode, toggle the option in Preferences -> SQL Editor and reconnect. 0.000 sec

1 Answer

365 Team

Hi Nabin!
Thanks for reaching out.
To solve this problem, you need to follow the steps as suggested by Workbench. Here they are in more detail.

  1. Go to the main Menu and expand the Edit/Preferences…/SQL Editor  option.
  2. Scroll down and un-tick the Safe Updates mode.

3. Click “OK” to confirm.
4. Reconnect to the database by clicking the following icon from the centre of the screen.

5. Load the data from the employees.sql file once more. Execute the following command to set employees as a default database.

USE employees;

6. Retry executing your query.
Hope this helps.