Last answered:

19 Jul 2021

Posted on:

10 Mar 2021


Tensorboard Issues with Jupyter


When trying to open tensorboard from Jupyter notebook I run into the following error

ERROR: Could not find `tensorboard`. Please ensure that your PATH
contains an executable `tensorboard` program, or explicitly specify
the path to a TensorBoard binary by setting the `TENSORBOARD_BINARY`
environment variable.

When I open tensorboard from anaconda terminal with the same command the tensorboard runs successfully. However, there is nothing in the interface saying that there are no active dashboards.

I tried some workarounds like installing tf-nighlty but I get the same errors again.

My python version is 3.8 and the versions of tensorflow and tensorboard are 2.4.1 and my os is macos catalina.

Any clues on how to overcome this?

Thanks in advance

1 answers ( 0 marked as helpful)
Posted on:

19 Jul 2021



It probably happens because of some conflict between notebook and virtual environment.

An easy solution here would be just to specify TENSORBOARD_BINARY variable right in your notebook, so it won't interfere with global variables, before calling tensorboard like that:

os.environ['TENSORBOARD_BINARY'] = '/path/to/envs/my_env/bin/tensorboard'

A long-term solution would be to set up a variable for virtual environment.

Hope this helps.
365 Team

Submit an answer