Super learner
This user is a Super Learner. To become a Super Learner, you need to reach Level 8.
Last answered:

27 Jul 2022

Posted on:

21 Jul 2022

1

Resolved: It takes too long to run the code

Good morning. Every time I try to compile the "employees" file, at some time it gives me the error "Error code: 2013. Lost connection to MySQL server during query". The "Duration/Fetch" is always around 30 seconds where the error appears. Is there any way to increase that time to 1 minute for example? Are there any other ways to solve this problem? Thank you.

3 answers ( 1 marked as helpful)
Instructor
Posted on:

22 Jul 2022

0

Hi Alessandro!
Thanks for reaching out.

New versions of MySQL WorkBench have an option to change specific timeouts.
Please go to Edit → Preferences → SQL Editor → DBMS connection read time out (in seconds): 600 Changed the value to 6000. This will solve the issue. Thank you.



Hope this helps.
Best,
Tsvetelin

Super learner
This user is a Super Learner. To become a Super Learner, you need to reach Level 8.
Posted on:

22 Jul 2022

0

Actually it has worked after a lot of attempts, but it will be useful for the next time. Thank you very much!

Instructor
Posted on:

27 Jul 2022

0

Hi Alessandro!
You are very welcome!

Best,
The 365 Team

Submit an answer